Turbo 36 not performing

The place for Fairline discussions!
  • Advertisement

Re: Turbo 36 not performing

Postby TurboRoss » Sun Nov 19, 2017 9:30 am

Thank you both for the advice & pictures . I’m going armed with some floor lifting tools this afternoon :lol:

The port sender unit seems to read at the gauge helm position , the starboard side gauge is stuck at 1/4.

As we are unsure on the fuel quantity in that tank , I’m hoping that when we do find out it will explain the slight list to starboard that it has . The fuel crossover doesn’t balance it out either .

Thanks again for helping
TurboRoss
 
Posts: 22
Joined: Mon Oct 30, 2017 6:48 pm

Re: Turbo 36 not performing

Postby admin » Sun Nov 19, 2017 1:31 pm

As others have said, the first thing to do is get the bottom and props scrubbed. I'd also have a look at the fuel, preferably via the sender and see if it looks clean. At worst it will have some diesel bug, at best it might be a bit stale. Also, make sure you carry some spare fuel filter on board and make sure you know how to change them.
Follow us on Twitter.
For Stainless Steel letters and Fender Socks visit Smart Marine.
User avatar
admin
Site Admin
 
Posts: 596
Joined: Sat Feb 15, 2003 3:48 pm

Re: Turbo 36 not performing

Postby TurboRoss » Fri Nov 24, 2017 7:19 am

Will do thank you

:)
TurboRoss
 
Posts: 22
Joined: Mon Oct 30, 2017 6:48 pm

Previous

Return to Fairline Forum

Who is online

Users browsing this forum: Bing [Bot], Google Adsense [Bot] and 23 guests

  • Advertisement